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BioNSi Cytoscape app – User Instructions 
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Installing BioNSi 
- In Cytoscape menu bar: Apps > App manager 
- Go to the "Currently Installed" tab. Make sure a previous version of BioNSi is not 

installed. If an older version is installed: 
o Choose the old BioNSi version and click Uninstall 
o Close Cytoscape and then open it again.  
o Open the App Manager again 

- Under "Install Apps" tab, click "Install from File". 
- You should see a new menu, a graph button, and a replay button. All BioNSi features 

are controlled from this menu. 
 

 

Creating a New BioNSi Network 
- BioNSi >New Network 
- There can only be one BioNSi network open at all times. 

 

Opening a Previously Saved BioNSi Network 
- BioNSi >New Network 
- File > Open 
- Choose your file (extension .cys) 

Saving a BioNSi Network 
- The same as saving any project in Cytoscape: File>save 
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Building and Editing Your BioNSi Network 

Add new node 
- Right click on the canvas > Add >Node. A "new Node" dialog box is opened. 
- Set node's properties and press Ok. 
- The new node will appear on the canvas. 

 

- Node names should be unique in the network. If a name identical to a node that 
already exists in the network is inserted a number will automatically be added to the 
end of the new nodes’ name. 

- The color you will choose for your node will also be used to represent this node in 
the chart showing network step-by-step simulations. We recommend choosing 
different colors so you will be able to easily understand the results chart. 

- Node shape is only a visual property - you can choose it as you wish. 
- Regular nodes have 2 main properties:  

a. initial state – can be set between 0 and 9. 
b. maximum state limit - can be set between 0 and 9. (This is independent of 

the initial state and can be set higher, lower or equal to it) 
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- Timed node: Has 3 properties you can set. Unlike regular nodes, timed nodes states 
are not influenced by the changes in the network during a simulation run. (Usage 
example: pulse of light, day and night, injection). 

a. Time table - list of timed events. Each row describes a state and the amount 
of time that the node will be set to this state. 

b. Lag - step in simulation the timed node will enter and start following its pre-
set time table. 

c. Cyclic - determine if the events in the time table will occur once or 
repeatedly. If left unmarked – the state after this will be 0. 

Add new edge 
- Right click on the source node > Add >Edge 
- Draw the edge to the desired target node. 
- Set edge properties in the opened "New Edge" dialog box and press Ok.  

a. Weight - the relative strength of the effect of the source node on the target 
node 

b. Delay - the number of simulation steps that the effect of the source node on 
target node will be delayed. If set to 0 (the default), the effect will take place 
right in the next simulation step. 

c. Dependencies - a set of rules conditioning when the edge is activated. If the 
conditions do not hold in a specific step in the simulation, the edge will be 
inactive in that step (as if it were temporarily deleted). The rules describe 
the effect of other nodes on the edge being edited. The conditions are of the 
form "node X is in state more than Y" or "node X is in state less than Y". In 
addition, one needs to set how many of the conditions should hold together 
for the current edge to be active.  

- The new edge will appear on canvas. 
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Edges Graphical Representation 
- Edge with a positive weight: 
- Edge with a negative weight: 
- Edge with weight higher (lower) than 1 (-1), the weight will annotate the edge in the 

graphical view. 
 

 - Edge with delay will be dashed: 
 

 
- Dependencies of the edge:  the figure shows 

an example case, where the activation of A 
by B depends on both C and D. 

- Dependency edges are grey (edges from C 
and D) 

- The shape of a dependency node  (created 
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automatically when you create an edge with dependencies) is determined  by the 
sufficient number of rules (that hold)  in order to activate the edge: 

a. All of the rules hold - triangle   

b. At least 1 of the rules holds - arrow  
c. At least k of the rules hold (k is determined by you) - square  

 

Edit node 
- Right click on node > BioNSi> Edit node 

Edit edge 
- Right click on edge > BioNSi> Edit edge 

Delete node/edge 
- Save the project (recommended) 
- Click on the object you wish to delete 
- Press Delete button on your keyboard 

There are some known issues when deleting an object in Cytoscape. If you follow these 
instructions, you'll probably be able to delete an object successfully: 

- If nothing happens after pressing "Delete" 
a. Close  and open Cytoscape again 
b. BioNSi >Build BioNSi network 
c. File>open 
d. Choose your saved project 

- If a deletion was made: verify that the deletion went OK : 
a. Deleting a node incoming and outgoing edges from that node should have 

been deleted too. 
b. Deleting a dependant node or deleting a dependant edge (full line) all 

edges connected to it should have been deleted, and a normal edge should 
have been created instead (in the figure above all edges will be deleted and 
an edge between B and A will be created). 

c. Deleting a depend edge (grey line) when there aren't any other grey line 
(representing other dependencies on the edge) connected to that depend 
node depend node should have been deleted. 

- If you have found any abnormality, restart Cytoscape, load your saved project and 
try to delete again. 
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Easy editing of BioNSi network properties in a table 
Another way to edit properties of objects in your network is via the tables in the "Edit 
Network" dialog box, which allows easy editing of multiple objects in the same place. 

- BioNSi > Edit network in table 
- Press Ok in order to apply the changes to the network. 

 

- Properties of nodes, edges and dependencies can be edited within the table by 
clicking on the relevant cell and entering the new value. 

- Objects' names are not editable from this dialog (only from the "edit node" option). 

- Timed nodes do not appear in these tables. You can only edit their properties 
individually (see page 5, edit node).  
** In the edges table the delay value will only be set after pressing “Enter”** 
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Run Network Simulation 

- BioNSi > Run Simulation, or use the button on the left side of the tool-bar: 
- Choose the running mode (constant\logarithmic), and when to stop running the 

simulation: 
a. after the simulator identified a loop or a steady state,  

 If a network has timed nodes,  the simulation will not search for a 
loop/steady-state before the last (maximal) lag time of all timed 
nodes came into play 

b. after a pre-defined number of steps. 
-  You can also fill in a title for the simulation ("Tab Name"). 
-  Press Ok. 

 
 

- A new tab in the Results Panel will be opened (if you accidentally close the results 
panel, use View>Show Results Panel) 
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- Top message: There are 3 options for the message that appears on top: 

a. "System has reached steady-state after # steps"   
b. "Loop detected between step # and step #" 
c. When setting the number of steps manually, the message will be "Model ran 

for # steps", followed by the detected loop or steady-state steps, if the 
system has reached a loop or steady state within the chosen number of 
steps. 

- The graph: x-axis shows the states, y-axis shows the steps. Each node is represented 
by a line with the same color as the node in the network. 

- Nodes list: Click on a node name (the list on the left) in order to hide it from the 
graph. You can click and drag your mouse over the list in order to hide more than 
one node. Click again on a hidden node to make it visible again in the graph.  

- Export to table: Used to create a .csv file (opens for example in Excel). The file 
includes the simulation results in a table (nodes states per step) and summary of the 
network properties on that run. This network summary is in the same format as the 
file created from "Export Network" action (see below). 

- Notes: You can use the "Notes" text box for some quick self-reference (for example, 
document the parameters of the specific run). The notes are not saved after the tab 
is closed, or after Cytoscape is closed. 

Replay Network Simulation 
 The parameters inserted when running a simulation (running mode, number of 
steps, tab name) are saved and “Replay Run” can be used to run simulations without 
needing to insert them again. 

- BioNSi > Replay Run or use the button on the left side of the tool-bar: 
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Statistical Mode  
The statistical mode allows you to run a large amount of simulations and gather statistical 
information about your network. 

- BioNSi > Run Statistical Mode > Regular Nodes 

 

- Fill in the running mode of all the simulations (logarithmic/constant). 
- Choose an indicator node. The analysis will focus on the indicator node's states. 
- Choose the nodes for which you want to run the simulations with a range of initial 

states. (We later relate to these nodes as "statistical nodes"). Notice that the 
number of simulation that will run is updated on the right.  

- When pressing ok, the program will run a simulation for every possible combination 
of node states (that were chosen in the table). The other nodes' initial states will 
remain as they were originally set in the network.  

- We do not recommend running more than one million runs, because running time is 
long. 
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- BioNSi > Run Statistical Mode > Timed Nodes 
 

 

- Fill in the running mode of all the simulations (logarithmic/constant). 
- Choose an indicator node. The analysis will focus on the indicator node's states. 
- Choose the timed node for which you want to run the simulations. The lag, initial 

state and duration fields are all text boxes that can hold multiple values separated 
by commas. Here are some examples to better understand the combination 
possibilities: 

a. Lag: 50,100,150 

State Duration 
9 13 
0 13 

 Will result in running 3 simulations with the same timetable and different lag times. 

b. Lag: 50 
  

State Duration 
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9,6 13 
0,0 13 

Will result in running 2 simulations, with two different timetables: 

State Duration   State Duration 
9 13   6 13 
0 13   0 13 

 
c. Lag: 50 

State Duration 
9 13, 26 
0 13,26 

Will result in running 2 simulations as well with the following timetables: 

State Duration   State Duration 
9 13   9 26 
0 13   0 26 

 
d. Lag: 50 

State Duration 
9,6 13,26 
0,0 13,26 

  This time we will run 4 different combinations: 

State Duration   State Duration   State Duration   State Duration 
9 13   6 13   9 26   6 26 
0 13   0 13   0 26   0 26 

   

- Notice that all fields must have the same number of values so in examples b and d 
we insert “0,0” to match the number of states in the first row even though the 
actual value doesn’t change.   

 
 

Statistical analysis results 
After running the simulations the results panel will contain the following tabs: 

Stats Summary tab: 
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- Table summarizing all the simulations results :  
a. Simulation results: steady-state or loop. 

 Loop results are grouped together according to the loop states of 
the chosen indicator node. 

 Steady-state results are grouped together according to the end 
states of all of the nodes in the network. 

b. The percentage of the simulations in which the system has reached the 
same result. 

c. Loop size (number of steps, 0 for steady state) 
d. Initial setting example – A "representative" for the initial states of the 

statistical nodes in which the system has reached this specific result. 
e. Average run length until reaching loop\steady-state, over all initial 

configurations that led to that loop\steady-state. 
- Distribution of initial states: 

- Available only when running the statistical mode on regular nodes. 
- Opens a panel with different tabs for each result encountered during the 

simulations and two general tabs – “distribution over all loops” and 
“distribution over all steady-states” 

- Each tab shows a table that presents how many times the initial state of the 
nodes resulted in that loop/steady-state. 
For example, in the following table the simulations reached 3 different loops 
and 1 steady-state and you can see that “Loop1” occurred 3 times and only  
when the node “Clock” was in state 2 
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- View loop/steady-state start times: 

a. Available only when running the statistical mode on timed nodes. 
b. Here the tables show the distribution of the loops/steady-states start times 

for each result reached during the simulation runs. 
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Importing a BioNSi network 
- BioNSi >File Operations>Import Network 
- The imported file must be a CSV file (make sure it is saved that way in Excel): 

** Note that to ensure that the information is imported properly, due to the CSV 
properties you can’t use commas in any of the fields** 

- Regular nodes table: 
a. Node – the name of the node, this field can’t be left empty. 
b. Initial State - this field can’t be left empty. 
c. Max State - this field can’t be left empty. 
d. Shape – can be one of "Rectangle", "Diamond", "Ellipse", "Hexagon", 

"Triangle". If left empty the rectangle shape will be used as the default. 
e. Color – A hex string of the color, for example: #ff6666. If left empty #0000ff 

(blue) will be used as the default color 
f. Position(x;y) – the position of the node on the canvas. If left empty the 

nodes will be positioned in a grid. (Layout can then be changed with all of 
Cytoscapes’ layout options in the “Layout” menu)  

- Timed nodes table: 
a. Node,Shape,Color,Position(x;y)  - same as the fields in the regular nodes 

table 
b. Entry Step – represents the “lag”, this field can’t be left empty 
c. Repeating – TRUE/FALSE field representing whether the node is cyclic or 

not. This field can’t be left empty. 
d. Timed Expression (State:duration) – should match the time table in the “add 

node” panel. There can be more than one timed expression  per timed node,  
In which case they should appear in the same row. 

- Edges table: 
a. Source Node – this field can’t be left empty and must contain the name of a 

node that appears in the regular or timed nodes tables. 
b. Target Node– this field can’t be left empty and must contain the name of a 

node that appears in the regular or timed nodes tables. 
c. Weight – a positive or negative integer, this field can’t be left empty. 
d. Delay – must be 0 or higher, this field can’t be left empty. 
e. Sufficient number of rules – a number specifying when the condition holds. 

Can be between 0 and the number of the dependencies in that row. 
f. Dependencies –  

 conditions of the form "node X is in state more than Y" or "node X is 
in state less than Y" 

 There can be more than one dependency per edge, In which case 
they should appear in the same row 
 



16 
 

Exporting a BioNSi network 
Exports all of the data in the current network to a given CSV file. This file can then be 
used to import the network. 
The file can be opened with excel  and you can use all the Excel features on the 
tables (for example, sorting by a specific column).  
 

- BioNSi >File Operations>Export Network 
- Choose a directory and file name and press “Save”. The file will be created it the 

selected directory. 
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